top of page

GrowinGoodness Group

Public·15 members
Benjamin James
Benjamin James

Backtrack 5 Wifi Drivers |WORK|

For later versions of the 2.6 kernel (as well as recent kernels), the smp_lock.h was removed. What used to be contained therein was moved into . To successfully install the ALFA drivers, however, it is necessary to take a couple of extra steps. This is taken from the most recent release of BackTrack R5:

backtrack 5 wifi drivers


I think it would be more trouble than it is worth. Plus BT is a live CD so why on earth would you run it virtualized? There are certain features that need special drivers for direct hardware access. This will be unreasonable to accomodate through an extra virtualized hardware abstraction layer.

  • Download BackTrack 5R1 Instructions:Navigate to one of the following URLs -images/backtrack-5/backtrack-5r1-gnome-i386/BT5R1-GNOME-32.iso

  • Click the Save File Radio Button

  • Click the OK Button

  • Download LocationInstructions:Navigate to a desired destination location of your choosing.In my case, I will save BT5R1-GNOME-32.iso toE:\ISOs, which is my external usb drive.

  • Click the OK Button

Compat-wireless is a package which contains the development and stable versions (pulled from the kernel's git repository) of the in-kernel wireless drivers and the mac80211 wireless stack. New packages are released pretty much every day.

This package is mentioned quite often on the forums and the IRC channel because using it is very convenient. You can think of it (in fact, you should) as a sized-down version of the kernel tree, a one that contains only the sources of the wireless drivers and the wireless stack. Therefore, you can apply any wireless-related patches to it and recompile them without having to recompile the whole kernel.

Additionally, the development versions of the drivers have one particular advantage : they're being constantly improved. It is not uncommon to see that they support more hardware, have better performance, or simply contain fixes to various bugs - in contrast to their stable versions. However, you should always remember that development versions may be incomplete or contain even more bugs than the stable ones.

We distinguish two versions of compat-wireless, development (bleeding edge) and stable. The development version may include more drivers, supported hardware and bug-fixes but may not be as stable as the 'stable' version which implies its nature. With minor exceptions, both versions will suffice in your bid to enable aircrack-ng support for your card/driver. For the majority of the users the stable version is the preferred one to use

compat-wireless offers one very useful script, called driver-select, which allows you to save time when compiling your preferred driver. Currently not all drivers are available via driver-select but the most common ones are. Its useful if you install compat-wireless frequently or if you have one card on your computer. Enter the compat-wireless directory and issue:

DO NOT use the steps referenced in this article to install or uninstall Windows DCH drivers, as doing so bypasses the Intel installer designed to install these new drivers, thereby possibly resulting in minor to major system instability.

Just installed RedHat 8. Noticed that I'm unable to connect to wifi. Going into "Settings->Wi-Fi" shows the message "No Wi-Fi Adapter Found...make sure you have a Wi-Fi adapter plugged and turned on". In the status bar up at the top there is also no wifi icon indicator either. My friend and I both have the same laptops (E480 Thinkpads) and he happened to see the same thing when he installed Centos7. So it appears to not be specific to my setup. Prior to installing RedHat I had Ubuntu installed and the wifi was working fine. So I'm stuck on why it's not working with RedHat and need some help. I included some more details below.

I've also gone in and took a look at /lib/firmware/rtlwifi to see if the firmware for my wifi adapter was there and it is. This was recommended from a similar discussion. I can see the rtl8822befw.bin file there. However, I'm not too sure how to proceed knowing that it's there. A colleague referred me to a ubuntu post suggesting sudo rmmod ideapad_laptop. However, running that command leads to...

Since then I have restarted my system to ensure the wifi still works properly and it is. Since you added to the elrepo for Centos8/RHEL8 how can we port it over to the elrepo for Centos7/RHEL7? I hate to even ask since you've went above and beyond already but wanted to kindly ask.

hi everyone, i have RHEL 8.4 but the wifi driver is not availble PFAlspci -nn grep 88210000:02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]

Please note that Wifi drivers often break and need rebuilding against new point releases, so we may need to rebuild the driver for el7.7 and el8.1 once they are released. If the driver stops working after an update, please feel free to file a bug request at and either Akemi or I will fix it.

Hi Philip, I am hitting the exact same issue: What I have done is: Install Redhat release is rhel7.6, download kmod-r8822be-0.0-1.el7_6.elrepo.x86_64.rpm and install it sucessfully. However, the modprobe command failed : modprobe:error: could not insert r88wwbe: Required key not available. The wifi adapter is rtl8822BE.

Hi, thanks for the reply. already bought a wifi adapter and its working fine. But many will be facing issue with this adapter and mine is a brand new one. In windows there is no issue at all, so any other solutions will be appreciated. thanks in advance

I have similar situation to Sangram's, I am on a Lenovo T420 and wifi was working well on RH 7.8, I installed yesterday 8.1 and wifi is out... I can't start it at all and nmcli device wifi rescan says No Wi-Fi device found. I am guessing this could be because of the driver as I have tried every other solution I could find to start the device with no success.

I can confirm I'm using iwlwifi driver, I can't send you the lspci at the moment as I have no internet at all, tried an ethernet cable but I still can't seem to get to the outside world... I will try to write down the most important stuff and write it again here, in the mean time I will see why I don't get internet with the cable as well.

Thank you! This works great. The wireless network on my laptop became unreliable after upgrading to Ubuntu 16.04 LTS. I too experienced no wifi after waking up from sleep. Also the wifi would at random. die for no apparent reason and the only that worked was a full reboot of the laptop.

One trend I've noticed with Ubuntu Software Center is that often it installs 90% of a package and never "finishes" installing the package - and this is what happened again. Regardless, what has worked in the past is to close Ubuntu Software Center (which I did). The package was installed as far as I could tell, but in terminal, I tried "sudo modprobe -r wl" and got the response "wl is busy" so I restarted my pc. Lo and behold, after restart and third attempt at this line "sudo modprobe -r wl" my wifi indicator immediately lit up and it seems to be working fine. Thank you kindly for your help. I just wanted to let fellow linux users know that this worked for me, and also how I had to get it to work. Cheers!

PS I am running on 2gb of ddr2 ram, with a dual-core processor @ approx 1.85ghz... Which means I still prefer backtrack 5 / ubuntu 10.04 for my daily computing needs/desires. I feel ubuntu 12 and 14 (I did not try 13) are too bloated, and while there are some nice ideas I see coming to life, they do not to my knowledge follow the KISS method. Thanks anyways :) I will still give ubuntu 14 a shot on this machine. Much love

I might keep ubuntu 14, due to the fact that I am unable to get flash player working in either chromium or firefox with backtrack 5 / ubuntu 10.04; if anyone out there has found a workaround, please send me a link @ Thank you!

Apart from that, there are some issues with BT5 and wireless drivers atm - i would ask you to stick to the official BackTrack Forums for more help with that. There are several posts that might bring you forward.

This talk will introduce techniques to detect Wi-Fi attacks such as Honeypots, Evil Twins, Mis-association , Hosted Network based backdoors etc. on a Windows client without the need for custom hardware or drivers. Our attack detection techniques will work for both Encrypted (WPA/WPA2 PSK and Enterprise) and Unencrypted networks.

Dear sir,I install back track 5r1 but i want to my wifi password. I face some problem1-Wifi network adapter?2-where i can buy in India?3-how much rupees in Indian currency? Sir plz help me .

I had the same Atheros AR5007EG as the internal wireless on my old Toshiba Satellite. I could never get mine to work. Unless they have new drivers for it than more than likely you will have to buy a compatible USB adapter.

An adapter that has a bigger dBi antenna will have better range but many use boosters in combination with bigger antenna to get real distance. Boosters and bigger antennas can always be added later if needed. Here is a post about this. -range-wifi-antenna-and-boosters.html

Ok guys, I am an arch user for a good while now (1 month, ehehe), but I am not even close to a tech savy for now. I wanted to try today the aircrack injection in arch. It works flawlessly in backtrack 5. Now ... I get an error something about mon0 channel and access point channel. A bit of research, gave me some results from google.

I have a 64 bit system and I tried to boot up with Security Onion 12.04 64 bit iso in order to install it on my hdd. Grub menu appears to work fine however, when Live Desktop environment tries to load, it freezes with the following characteristics:- the mouse pointer is able to move around.- no desktop icons are present.- "no wireless connection" notification is present on the top right in a frozen state not responsive to mouse clicks.- no other objects/icons respond to mouse clicks.I have also tried the direct installer option in grub menu and it also freezes with no wizards appearing on screen.Previously, on this system I have used/installed the following 64 bit systems:-Backtrack 5 R3-windows pro-ubuntu -centos-fedoraNone of them presented a problem. Moreover, on the same system, using the same iso dvd, I tried installing the 12.04 64bit inside a vm in virtual box(on windows host) and everything works fine and the installation completes with no problems at all so I'm assuming the dvd is fine.So I'm wondering what is causing the problem? could it be the graphic drivers or wifi nic drivers ?


Welcome to the group! You can connect with other members, ge...


Group Page: Groups_SingleGroup
bottom of page